twentyfifteen_upgrade_notice

Add message for unsuccessful theme switch.

Description

twentyfifteen_upgrade_notice(); 

Prints an update nag after an unsuccessful attempt to switch to Twenty Fifteen on WordPress versions prior to 4.1.


Usage

  1. if ( !function_exists( 'twentyfifteen_upgrade_notice' ) ) { 
  2. require_once '/inc/back-compat.php'; 
  3.  
  4.  
  5. // NOTICE! Understand what this does before running. 
  6. $result = twentyfifteen_upgrade_notice(); 
  7.  

Defined (1)

The function is defined in the following location(s).

/inc/back-compat.php  
  1. function twentyfifteen_upgrade_notice() { 
  2. $message = sprintf( __( 'Twenty Fifteen requires at least WordPress version 4.1. You are running version %s. Please upgrade and try again.', 'twentyfifteen' ), $GLOBALS['wp_version'] ); 
  3. printf( '<div class="error"><p>%s</p></div>', $message );