evolve_register_suggested_plugins

The evolve evolve register suggested plugins function.

Description

evolve_register_suggested_plugins(); 

Usage

  1. if ( !function_exists( 'evolve_register_suggested_plugins' ) ) { 
  2. require_once '/library/admin/tgm/tgm-init.php'; 
  3.  
  4.  
  5. // NOTICE! Understand what this does before running. 
  6. $result = evolve_register_suggested_plugins(); 
  7.  

Defined (1)

The function is defined in the following location(s).

/library/admin/tgm/tgm-init.php  
  1. function evolve_register_suggested_plugins() { 
  2. /** 
  3. * Array of plugin arrays. Required keys are name and slug. 
  4. * If the source is NOT from the .org repo, then source is also required. 
  5. */ 
  6. $plugins = array( 
  7. array( 
  8. 'name' => 'Redux Framework', // The plugin name 
  9. 'slug' => 'redux-framework', // The plugin slug (typically the folder name) 
  10. 'required' => false, // If false, the plugin is only 'recommended' instead of required 
  11. 'version' => '3.6.3', // E.g. 1.0.0. If set, the active plugin must be this version or higher, otherwise a notice is presented 
  12. 'force_activation' => false, // If true, plugin is activated upon theme activation and cannot be deactivated until theme switch 
  13. 'force_deactivation' => false, // If true, plugin is deactivated upon theme switch, useful for theme-specific plugins 
  14. ),  
  15. ); 
  16.  
  17. /** 
  18. * Array of configuration settings. Amend each line as needed. 
  19. * If you want the default strings to be available under your own theme domain,  
  20. * leave the strings uncommented. 
  21. * Some of the strings are added into a sprintf, so see the comments at the 
  22. * end of each line for what each argument will be. 
  23. */ 
  24. $config = array( 
  25. 'default_path' => '', // Default absolute path to pre-packaged plugins 
  26. 'menu' => 'install-required-plugins', // Menu slug 
  27. 'has_notices' => true, // Show admin notices or not 
  28. 'is_automatic' => false, // Automatically activate plugins after installation or not 
  29. 'message' => '', // Message to output right before the plugins table 
  30. 'strings' => array( 
  31. 'page_title' => __('Install Required Plugins', 'evolve'),  
  32. 'menu_title' => __('Install Plugins', 'evolve'),  
  33. 'installing' => __('Installing Plugin: %s', 'evolve'), // %1$s = plugin name 
  34. 'oops' => __('Something went wrong with the plugin API.', 'evolve'),  
  35. 'notice_can_install_required' => _n_noop('This theme requires the following plugin installed or update: %1$s.', 'This theme requires the following plugins installed or updated: %1$s.', 'evolve'), // %1$s = plugin name(s) 
  36. 'notice_can_install_recommended' => _n_noop('This theme recommends the following plugin installed or updated: %1$s.', 'This theme recommends the following plugins installed or updated: %1$s.', 'evolve'), // %1$s = plugin name(s) 
  37. 'notice_cannot_install' => _n_noop('Sorry, but you do not have the correct permissions to install the %s plugin. Contact the administrator of this site for help on getting the plugin installed.', 'Sorry, but you do not have the correct permissions to install the %s plugins. Contact the administrator of this site for help on getting the plugins installed.', 'evolve'), // %1$s = plugin name(s) 
  38. 'notice_can_activate_required' => _n_noop('The following required plugin is currently inactive: %1$s.', 'The following required plugins are currently inactive: %1$s.', 'evolve'), // %1$s = plugin name(s) 
  39. 'notice_can_activate_recommended' => _n_noop('The following recommended plugin is currently inactive: %1$s.', 'The following recommended plugins are currently inactive: %1$s.', 'evolve'), // %1$s = plugin name(s) 
  40. 'notice_cannot_activate' => _n_noop('Sorry, but you do not have the correct permissions to activate the %s plugin. Contact the administrator of this site for help on getting the plugin activated.', 'Sorry, but you do not have the correct permissions to activate the %s plugins. Contact the administrator of this site for help on getting the plugins activated.', 'evolve'), // %1$s = plugin name(s) 
  41. 'notice_ask_to_update' => _n_noop('The following plugin needs to be updated to its latest version to ensure maximum compatibility with this theme: %1$s.', 'The following plugins need to be updated to their latest version to ensure maximum compatibility with this theme: %1$s.', 'evolve'), // %1$s = plugin name(s) 
  42. 'notice_cannot_update' => _n_noop('Sorry, but you do not have the correct permissions to update the %s plugin. Contact the administrator of this site for help on getting the plugin updated.', 'Sorry, but you do not have the correct permissions to update the %s plugins. Contact the administrator of this site for help on getting the plugins updated.', 'evolve'), // %1$s = plugin name(s) 
  43. 'install_link' => _n_noop('Begin installing plugin', 'Begin installing plugins', 'evolve'),  
  44. 'activate_link' => _n_noop('Activate installed plugin', 'Activate installed plugins', 'evolve'),  
  45. 'return' => __('Return to Required Plugins Installer', 'evolve'),  
  46. 'plugin_activated' => __('Plugin activated successfully.', 'evolve'),  
  47. 'complete' => __('All plugins installed and activated successfully. %s', 'evolve'), // %1$s = dashboard link 
  48. 'nag_type' => 'updated' // Determines admin notice type - can only be 'updated' or error 
  49. ); 
  50.  
  51. //mod by denzel, show install plugin ability to administrators only,  
  52. //so that subscribers or other roles will not see this at all! 
  53. if (current_user_can('administrator')) { 
  54. tgmpa($plugins, $config);