yit_check_plugin_support

Check the framework core version.

Description

yit_check_plugin_support(); 

Usage

  1. if ( !function_exists( 'yit_check_plugin_support' ) ) { 
  2. require_once ABSPATH . PLUGINDIR . 'yith-woocommerce-wishlist/plugin-fw/yit-functions.php'; 
  3.  
  4.  
  5. // NOTICE! Understand what this does before running. 
  6. $result = yit_check_plugin_support(); 
  7.  

Defined (1)

The function is defined in the following location(s).

/plugin-fw/yit-functions.php  
  1. function yit_check_plugin_support () { 
  2.  
  3. $headers[ 'core' ] = wp_get_theme ()->get ( 'Core Framework Version' ); 
  4. $headers[ 'author' ] = wp_get_theme ()->get ( 'Author' ); 
  5.  
  6. if ( ! $headers[ 'core' ] && defined ( 'YIT_CORE_VERSION' ) ) { 
  7. $headers[ 'core' ] = YIT_CORE_VERSION; 
  8.  
  9. if ( ( ! empty( $headers[ 'core' ] ) && version_compare ( $headers[ 'core' ], '2.0.0', '<=' ) ) || $headers[ 'author' ] != 'Your Inspiration Themes' ) { 
  10. return true; 
  11. } else { 
  12. return false;