woo_cp_lite_upgrade_plugin

The WooCommerce Compare Products LITE woo cp lite upgrade plugin function.

Description

woo_cp_lite_upgrade_plugin(); 

Usage

  1. if ( !function_exists( 'woo_cp_lite_upgrade_plugin' ) ) { 
  2. require_once ABSPATH . PLUGINDIR . 'woocommerce-compare-products-lite/admin/compare_init.php'; 
  3.  
  4.  
  5. // NOTICE! Understand what this does before running. 
  6. $result = woo_cp_lite_upgrade_plugin(); 
  7.  

Defined (1)

The function is defined in the following location(s).

/admin/compare_init.php  
  1. function woo_cp_lite_upgrade_plugin () { 
  2. global $wc_compare_less; 
  3.  
  4. // Upgrade to 2.0.0 
  5. if(version_compare(get_option('a3rev_woocp_pro_version'), '2.0.0') === -1) { 
  6. include( WOOCP_DIR. '/includes/updates/compare-update-2.0.0.php' ); 
  7. update_option('a3rev_woocp_pro_version', '2.0.0'); 
  8. // Upgrade to 2.0.1 
  9. if(version_compare(get_option('a3rev_woocp_pro_version'), '2.0.1') === -1) { 
  10. include( WOOCP_DIR. '/includes/updates/compare-update-2.0.1.php' ); 
  11. update_option('a3rev_woocp_pro_version', '2.0.1'); 
  12. // Upgrade to 2.0.6 
  13. if(version_compare(get_option('a3rev_woocp_pro_version'), '2.0.6') === -1) { 
  14. include( WOOCP_DIR. '/includes/updates/compare-update-2.0.6.php' ); 
  15. update_option('a3rev_woocp_pro_version', '2.0.6'); 
  16. // Upgrade to 2.1.0 
  17. if(version_compare(get_option('a3rev_woocp_pro_version'), '2.1.0') === -1) { 
  18. include( WOOCP_DIR. '/includes/updates/compare-update-2.1.0.php' ); 
  19. update_option('a3rev_woocp_pro_version', '2.1.0'); 
  20.  
  21. // Upgrade to 2.1.8 
  22. if(version_compare(get_option('a3rev_woocp_pro_version'), '2.1.8') === -1) { 
  23. include( WOOCP_DIR. '/includes/updates/compare-update-2.1.8.php' ); 
  24. WC_Compare_Functions::lite_upgrade_version_2_1_8(); 
  25.  
  26. update_option('a3rev_woocp_pro_version', '2.1.8'); 
  27. update_option('a3rev_woocp_lite_version', '2.1.8'); 
  28.  
  29. // Upgrade to 2.1.9.3 
  30. if( version_compare(get_option('a3rev_woocp_lite_version'), '2.1.9.3') === -1 ) { 
  31. include( WOOCP_DIR. '/includes/updates/compare-update-2.1.9.3.php' ); 
  32. update_option('a3rev_woocp_lite_version', '2.1.9.3'); 
  33.  
  34. // Upgrade to 2.3.0 
  35. if( version_compare(get_option('a3rev_woocp_lite_version'), '2.3.0') === -1 ) { 
  36. update_option('a3rev_woocp_lite_version', '2.3.0'); 
  37.  
  38. // Build sass 
  39. $wc_compare_less->plugin_build_sass(); 
  40.  
  41. // Upgrade to 2.4.0 
  42. if ( version_compare(get_option('a3rev_woocp_lite_version'), '2.4.0') === -1 ) { 
  43. update_option('a3rev_woocp_lite_version', '2.4.0'); 
  44. update_option('wc_compare_product_style_version', time() ); 
  45.  
  46. // Upgrade to 2.5.0 
  47. if(version_compare(get_option('a3rev_woocp_lite_version'), '2.5.0') === -1) { 
  48. update_option('a3rev_woocp_lite_version', '2.5.0'); 
  49. include( WOOCP_DIR. '/includes/updates/compare-update-2.5.0.php' ); 
  50.  
  51. // Build sass 
  52. $wc_compare_less->plugin_build_sass(); 
  53.  
  54. update_option('a3rev_woocp_pro_version', '2.4.5'); 
  55. update_option('a3rev_woocp_lite_version', '2.5.4'); 
  56.