pods_version_notice_mysql

Show WP notice if MySQL version is incompatible.

Description

pods_version_notice_mysql(); 

Usage

  1. if ( !function_exists( 'pods_version_notice_mysql' ) ) { 
  2. require_once ABSPATH . PLUGINDIR . 'pods-custom-content-types-and-fields/includes/general.php'; 
  3.  
  4.  
  5. // NOTICE! Understand what this does before running. 
  6. $result = pods_version_notice_mysql(); 
  7.  

Defined (1)

The function is defined in the following location(s).

/includes/general.php  
  1. function pods_version_notice_mysql () { 
  2. global $wpdb; 
  3. $mysql = $wpdb->db_version(); 
  4. ?> 
  5. <div class="error fade"> 
  6. <p><strong><?php _e( 'NOTICE', pods ); ?>:</strong> Pods <?php echo esc_html( PODS_VERSION ); ?> <?php _e( 'requires a minimum of', pods ); ?> 
  7. <strong>MySQL <?php echo esc_html( PODS_MYSQL_VERSION_MINIMUM ); ?>+</strong> <?php _e( 'to function. You are currently running', pods ); ?> 
  8. <strong>MySQL <?php echo esc_html( $mysql ); ?></strong> - <?php _e( 'Please upgrade (or have your Hosting Provider upgrade it for you) your MySQL version to continue.', pods ); ?> 
  9. </p> 
  10. </div> 
  11. <?php