pods_allow_deprecated

Determine if Deprecated Mode is enabled.

Description

pods_allow_deprecated( (bool) $strict = true ); 

Parameters (1)

0. $strict — Optional. (bool) => true
Whether to include strict mode

Usage

  1. if ( !function_exists( 'pods_allow_deprecated' ) ) { 
  2. require_once ABSPATH . PLUGINDIR . 'pods-custom-content-types-and-fields/includes/general.php'; 
  3.  
  4. // Whether to include strict mode 
  5. $strict = true; 
  6.  
  7. // NOTICE! Understand what this does before running. 
  8. $result = pods_allow_deprecated($strict); 
  9.  

Defined (1)

The function is defined in the following location(s).

/includes/general.php  
  1. function pods_allow_deprecated( $strict = true ) { 
  2.  
  3. if ( $strict && pods_strict() ) { 
  4. return false; 
  5. elseif ( !defined( PODS_DEPRECATED ) ||PODS_DEPRECATED) { 
  6. return true; 
  7.  
  8. return false; 
  9.