pmpro_upgrade_1_4_2

The Paid Memberships Pro pmpro upgrade 1 4 2 function.

Description

pmpro_upgrade_1_4_2(); 

Usage

  1. if ( !function_exists( 'pmpro_upgrade_1_4_2' ) ) { 
  2. require_once ABSPATH . PLUGINDIR . 'paid-memberships-pro/includes/updates/upgrade_1_4_2.php'; 
  3.  
  4.  
  5. // NOTICE! Understand what this does before running. 
  6. $result = pmpro_upgrade_1_4_2(); 
  7.  

Defined (1)

The function is defined in the following location(s).

/includes/updates/upgrade_1_4_2.php  
  1. function pmpro_upgrade_1_4_2() 
  2. /** 
  3. Setting the new use_ssl setting. 
  4. PayPal Website Payments Pro, Authorize.net, and Stripe will default to use ssl. 
  5. PayPal Express and the testgateway(no gateway) will default to not use ssl. 
  6. */ 
  7. $gateway = pmpro_getOption("gateway"); 
  8. if($gateway == "paypal" || $gateway == "authorizenet" || $gateway == "stripe") 
  9. pmpro_setOption("use_ssl", 1); 
  10. else 
  11. pmpro_setOption("use_ssl", 0); 
  12.  
  13. pmpro_setOption("db_version", "1.42"); 
  14. return 1.42;