CWS_Google_Picasa_Pro_Activator

Fired during plugin activation.

Defined (2)

The class is defined in the following location(s).

/includes/class-cws-google-picasa-pro-activator.php  
  1. class CWS_Google_Picasa_Pro_Activator { 
  2.  
  3. /** 
  4. * Short Description. 
  5. * Long Description. 
  6. * @since 1.0.0 
  7. */ 
  8. public static function activate() { 
  9.  
  10. $cws_gpp_options = array( 
  11. 'num_album_results' => 9,  
  12. 'num_image_results' => 4,  
  13. 'album_thumb_size' => 250,  
  14. 'thumb_size' => 200,  
  15. 'private_albums' => "All",  
  16. 'show_album_title' => 1,  
  17. 'show_album_details' => 0,  
  18. 'show_image_title' => 1,  
  19. 'imgmax' =>450,  
  20. 'results_page' => '',  
  21. 'hide_albums' => '',  
  22. 'theme' => '',  
  23. 'lightbox_image_size' => '',  
  24. 'enable_cache' => '',  
  25. 'row_height' => '250',  
  26. ); 
  27.  
  28. update_option( 'cws_gpp_options', $cws_gpp_options );  
  29.  
  30. // delete dismiss upgrade notice 
  31. $current_user = getCurrentUser(); 
  32. delete_user_meta( $current_user->ID, 'cws_gpp_ignore_upgrade' ); 
  1. class CWS_Google_Picasa_Pro_Activator { 
  2.  
  3. /** 
  4. * Short Description. 
  5. * Long Description. 
  6. * @since 1.0.0 
  7. */ 
  8. public static function activate() { 
  9.  
  10. $cws_gpp_options = array( 
  11. 'num_album_results' => 9,  
  12. 'num_image_results' => 4,  
  13. 'album_thumb_size' => 250,  
  14. 'thumb_size' => 200,  
  15. 'private_albums' => "All",  
  16. 'show_album_title' => 1,  
  17. 'show_album_details' => 0,  
  18. 'show_image_title' => 1,  
  19. 'imgmax' =>450,  
  20. 'results_page' => '',  
  21. 'hide_albums' => '',  
  22. 'theme' => '',  
  23. 'lightbox_image_size' => '',  
  24. 'enable_cache' => '',  
  25. 'row_height' => '250',  
  26. ); 
  27.  
  28. update_option( 'cws_gpp_options', $cws_gpp_options );  
  29.  
  30. // delete dismiss upgrade notice 
  31. $current_user = getCurrentUser(); 
  32. delete_user_meta( $current_user->ID, 'cws_gpp_ignore_upgrade' );