wpcf7_old_wp_version_error

The Contact Form 7 wpcf7 old wp version error function.

Description

wpcf7_old_wp_version_error(); 

Usage

  1. if ( !function_exists( 'wpcf7_old_wp_version_error' ) ) { 
  2. require_once ABSPATH . PLUGINDIR . 'contact-form-7/admin/admin.php'; 
  3.  
  4.  
  5. // NOTICE! Understand what this does before running. 
  6. $result = wpcf7_old_wp_version_error(); 
  7.  

Defined (1)

The function is defined in the following location(s).

/admin/admin.php  
  1. function wpcf7_old_wp_version_error() { 
  2. $wp_version = get_bloginfo( 'version' ); 
  3.  
  4. if ( ! version_compare( $wp_version, WPCF7_REQUIRED_WP_VERSION, '<' ) ) { 
  5. return; 
  6.  
  7. ?> 
  8. <div class="notice notice-warning"> 
  9. <p><?php echo sprintf( __( '<strong>Contact Form 7 %1$s requires WordPress %2$s or higher.</strong> Please <a href="%3$s">update WordPress</a> first.', 'contact-form-7' ), WPCF7_VERSION, WPCF7_REQUIRED_WP_VERSION, admin_url( 'update-core.php' ) ); ?></p> 
  10. </div> 
  11. <?php