bp_get_theme_compat_version

Get the version of the theme package being used.

Description

(string) bp_get_theme_compat_version(); 

This can be filtered or set manually. Tricky theme authors can override the default and include their own BuddyPress compatibility layers for their themes.

Returns (string)

The version string of the theme package currently in use.


Usage

  1. if ( !function_exists( 'bp_get_theme_compat_version' ) ) { 
  2. require_once ABSPATH . PLUGINDIR . 'buddypress/bp-core/bp-core-theme-compatibility.php'; 
  3.  
  4.  
  5. // NOTICE! Understand what this does before running. 
  6. $result = bp_get_theme_compat_version(); 
  7.  

Defined (1)

The function is defined in the following location(s).

/bp-core/bp-core-theme-compatibility.php  
  1. function bp_get_theme_compat_version() { 
  2.  
  3. /** 
  4. * Filters the version of the theme package being used. 
  5. * @since 1.7.0 
  6. * @param string $version The version string of the theme package in use. 
  7. */ 
  8. return apply_filters( 'bp_get_theme_compat_version',buddypress)->theme_compat->theme->version );