bp_get_theme_compat_id

Get the ID of the theme package being used.

Description

(string) bp_get_theme_compat_id(); 

This can be filtered or set manually. Tricky theme authors can override the default and include their own BuddyPress compatibility layers for their themes.

Returns (string)

ID of the theme package in use.


Usage

  1. if ( !function_exists( 'bp_get_theme_compat_id' ) ) { 
  2. require_once ABSPATH . PLUGINDIR . 'buddypress/bp-core/bp-core-theme-compatibility.php'; 
  3.  
  4.  
  5. // NOTICE! Understand what this does before running. 
  6. $result = bp_get_theme_compat_id(); 
  7.  

Defined (1)

The function is defined in the following location(s).

/bp-core/bp-core-theme-compatibility.php  
  1. function bp_get_theme_compat_id() { 
  2.  
  3. /** 
  4. * Filters the ID of the theme package being used. 
  5. * @since 1.7.0 
  6. * @param string $id ID of the theme package in use. 
  7. */ 
  8. return apply_filters( 'bp_get_theme_compat_id',buddypress)->theme_compat->theme->id );