bp_core_admin_maybe_disable_update_row_for_php53_requirement

Replaces WP's default update notice on plugins.php with an error message, when site is not running PHP 5.3 or greater.

Description

bp_core_admin_maybe_disable_update_row_for_php53_requirement(); 

Originally hooked to load-plugins.php with priority 100.


Usage

  1. if ( !function_exists( 'bp_core_admin_maybe_disable_update_row_for_php53_requirement' ) ) { 
  2. require_once ABSPATH . PLUGINDIR . 'buddypress/bp-core/deprecated/2.8.php'; 
  3.  
  4.  
  5. // NOTICE! Understand what this does before running. 
  6. $result = bp_core_admin_maybe_disable_update_row_for_php53_requirement(); 
  7.  

Defined (1)

The function is defined in the following location(s).

/bp-core/deprecated/2.8.php  
  1. function bp_core_admin_maybe_disable_update_row_for_php53_requirement() { 
  2. return; 
  3.  
  4. $loader = basename( constant( 'BP_PLUGIN_DIR' ) ) . '/bp-loader.php'; 
  5.  
  6. remove_action( "after_plugin_row_{$loader}", 'wp_plugin_update_row', 10 ); 
  7. add_action( "after_plugin_row_{$loader}", 'bp_core_admin_php52_plugin_row', 10, 2 );