bp_core_admin_is_running_php53_or_greater

Determines whether the current installation is running PHP 5.3 or greater.

Description

bp_core_admin_is_running_php53_or_greater(); 

BuddyPress 2.8 introduces a minimum PHP requirement of PHP 5.3.


Usage

  1. if ( !function_exists( 'bp_core_admin_is_running_php53_or_greater' ) ) { 
  2. require_once ABSPATH . PLUGINDIR . 'buddypress/bp-core/deprecated/2.8.php'; 
  3.  
  4.  
  5. // NOTICE! Understand what this does before running. 
  6. $result = bp_core_admin_is_running_php53_or_greater(); 
  7.  

Defined (1)

The function is defined in the following location(s).

/bp-core/deprecated/2.8.php  
  1. function bp_core_admin_is_running_php53_or_greater() { 
  2. return version_compare( PHP_VERSION, '5.3', '>=' );