bp_attachments_is_wp_version_supported

Check if the current WordPress version is using Plupload 2.1.1.

Description

bp_attachments_is_wp_version_supported(); 

Plupload 2.1.1 was introduced in WordPress 3.9. Our bp-plupload.js script requires it. So we need to make sure the current WordPress match with our needs.


Usage

  1. if ( !function_exists( 'bp_attachments_is_wp_version_supported' ) ) { 
  2. require_once ABSPATH . PLUGINDIR . 'buddypress/bp-core/bp-core-attachments.php'; 
  3.  
  4.  
  5. // NOTICE! Understand what this does before running. 
  6. $result = bp_attachments_is_wp_version_supported(); 
  7.  

Defined (1)

The function is defined in the following location(s).

/bp-core/bp-core-attachments.php  
  1. function bp_attachments_is_wp_version_supported() { 
  2. return (bool) version_compare( bp_get_major_wp_version(), '3.9', '>=' );