upgrade_290

Execute changes made in WordPress 2.9.

Description

upgrade_290(); 

Usage

  1. if ( !function_exists( 'upgrade_290' ) ) { 
  2. require_once ABSPATH . '/wp-admin/includes/upgrade.php'; 
  3.  
  4.  
  5. // NOTICE! Understand what this does before running. 
  6. $result = upgrade_290(); 
  7.  

Defined (1)

The function is defined in the following location(s).

/wp-admin/includes/upgrade.php  
  1. function upgrade_290() { 
  2. global $wp_current_db_version; 
  3.  
  4. if ( $wp_current_db_version < 11958 ) { 
  5. // Previously, setting depth to 1 would redundantly disable threading, but now 2 is the minimum depth to avoid confusion 
  6. if ( get_option( 'thread_comments_depth' ) == '1' ) { 
  7. update_option( 'thread_comments_depth', 2 ); 
  8. update_option( 'thread_comments', 0 );