http_request_version

Filters the version of the HTTP protocol used in a request.

Description

apply_filters( 'http_request_version', (string) _0 ); 

Parameters (1)

0. $1_0 (string) => '1.0'
Version of HTTP used. Accepts 1.0 and 1.1.. Default 1.0 .

Usage

To run the hook, copy the example below.
  1. $1_0 = apply_filters( 'http_request_version', $1_0 ); 
  2.  
  3. if ( !empty( $1_0 ) ) { 
  4.  
  5. // everything has led up to this point... 
  6.  
  7.  
The following example is for adding a hook callback.
  1. // define the http_request_version callback 
  2. function filter_http_request_version( $1_0 ) { 
  3. // make filter magic happen here... 
  4. return $1_0
  5. }; 
  6.  
  7. // add the filter 
  8. add_filter( 'http_request_version', 'filter_http_request_version', 10, 1 ); 
To remove a hook callback, use the example below.
  1. // remove the filter 
  2. remove_filter( 'http_request_version', 'filter_http_request_version', 10, 1 ); 

Defined (1)

The filter is defined in the following location(s).

/wp-includes/class-http.php  
  1. 'httpversion' => apply_filters( 'http_request_version', '1.0' ),